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10  Beam instability and stress stiffening (extract from the book e2) 

 

------- 

------- 

     Interesting knowledge can also be obtained by analyzing the effect of the geometric 

stiffness matrix on the overall stiffness of the element. For this purpose, we express the 

stiffness matrix of the beam finite element at its special position in Fig. 10.1. 
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Fig. 10. 1 

 

     The axis of the element is identical to the global axis x ( 0sinβ = , 1cosβ = ), the element 

is without bending load ( GM =K 0 ) and the pressure axial force was chosen to demonstrate 

later the loss of stability of the beam. The material and geometric matrix of such an element 

was determined from (9.19) using a simple program in Fig. 10.2. As could be assumed, based 

on what we have said about this matrix, the material stiffness matrix is identical to the linear 

stiffness matrix of the element expressed in the local coordinate system (eg [10, 18]). 

 

 

Fig. 10.2 

The global stiffness matrix of a single-element body rigidly fixed in node 1 and loaded by the 

compressive force F (Fig. 10.1) is obtained by omitting the first three rows and columns in 

both matrices, since these correspond to the removed (zero) degrees of freedom. 
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 (10.1) 

     A comparison of the matrix members in (10.1) shows a well-known knowledge of the 

technical practice: the compressive axial force of the beam decreases its transverse (bending) 

stiffness (decreases the absolute values of the members of the resulting matrix) and vice 

versa. In the first case we are talking about stress softening, in the second about stress 

stiffening. This is only relevant for slender (thin) structural members with low bending 

stiffness (slender beams and rods, cables, thin plates and shells) since in other cases the 

GK matrix members are negligibly small compared to the MK members. In general, the 

members of a geometric matrix are functions of the axial or membrane stress (in our simple 

example 0N = = -FSσ ) and therefore the geometric stiffness matrix is often called the stress 

stiffness matrix, or, in connection with the iterative process, the initial stress stiffness matrix, 

since the stress value known at the beginning of the step must be taken into the iteration step. 

     Since the geometrical stiffness matrix depends to a large extent only on the magnitude of 

the stress, its influence on the stiffness of the slender body can be of significant magnitude 

even for small displacement and rotation problems. Two typical examples of such a situation 

that need to be recognized in terms of the calculation procedure are illustrated by the beams in 

Fig. 10.3. 

 

 
 

                                                          Fig. 10.3 

 

     In the first case, it is a prestressed beam with a known prestressing force F independent of 

the force P. A classical linear FEM program, which does not have a built-in geometric matrix 

calculation, would solve this problem without affecting the force F on the deflection. With a 

significant amount of force F we would get unrealistic results. The same applies to the second 

example where the rigid constraints of the beam do not allow the axial movement of its ends, 

which causes a tensile force with a prestressing effect on the lateral deflection. 

    From the computational point of view these geometrically nonlinear problems differ from 

each other in the following: In the first case the axial force and hence the geometric matrix are 

known and the calculation can be performed without an iterative process; in the latter case, an 

iterative process is necessary to calculate the final value of the axial force and the geometric 

matrix. 

      The need to take into account stress stiffness is quite common in computational practice 

because it occurs in quasi-linear and non-linear problems not only at static but also at 
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dynamic loading (altered or varying stiffness affects the dynamic properties of the body) and 

induced not only by mechanical but also other types of loads: temperature load, initial and 

residual stresses in the material, etc.). The basic calculation procedures taking into account the 

stress stiffness will be shown in the ANSYS calculations of simple beams in fig. 10.3, 

however, the procedures are the same for complex real problems of this type. 

 
Example 10.1 

 

     Consider the beam shown in figure 10.3a. Assume that P = 100 N, F = 1000 N, l = 1 m, E = 

 2 10
11

 Pa, υ=  0.3, ρ  =  7850 kg / m
3
; The cross-section is a square with an area S = 1 cm

2
. 

Calculate: 

a) Maximum deflection of beam first without prestressing force F and then with it. 

b) The first natural vibration frequency of the beam without prestressing by force F and then 

with it. 

c) Adjust the beam as shown in fig. 10.3b and determine the maximum deflection.  

 
1. Job name 

Utility Menu>File>Change Jobname... /FILNAM = Buckling; 

2. Element type 

Preprocessor>Element Type>Add/Edit/Delete, Add, Beam, 2 node 188, OK, Close; 

3. Cross-sectional data 

Preprocessor>Sections>Beam> Common Sections, B = 0.01, H = 0.01, OK;  

4. Material properties 

Preprocessor>Material Props>Material Models, Favorites, Linear Static, Density, DENS = 7850, 

OK, Linear Isotropic, EX = 2e11,  PRXY = 0.3, OK, Material, Exit; 

5. Keypoints 

Plot Controls> Symbols, All Aplied BCs, OK; 

Preprocessor>Modeling>Create>Keypoints>In Active CS... X = 0, Y = 0, Apply, X = 1, Y = 0, 

Apply, X = 2, Y = 0, OK; 

6. The center line of the beam 

Preprocessor>Modeling>Create>Lines>Lines>Straight Line, Click: KP1, KP2, KP2, KP3, OK; 

7. Meshing  

Preprocessor>Meshing>Mesh Tool... Lines, Set, Pick All, Ndiv = 10, OK, Mesh, Pick All, Close; 

8. Fixation 

Main Menu>Solution>Define Loads>Apply>Structural>Displacement>On Keypoints, Click KP1, 

OK, All DOF, Apply, Click KP3, UY, UZ, ROTX, ROTY, OK;  

9. Loads 

Main Menu>Solution>Define Loads>Apply>Structural>Force/Moment>On Keypoints↑ P: KP2, OK,                         

FY = -100, Apply, Click KP3, OK, FX = 1000, OK; 

 SAVE_DB;  

10. Static solution without prestress but with the computation of the stress stiffnes matrix 

Solution>Analysis Type>New Analysis, Static, OK; 

Solution> Analysis Type>Sol'n Controls, Calculate prestress effects = ON, OK; 

Solution> Solve> Current LS, OK;  

11. Maximum deflection 

ANSYS Main Menu> General Postproc> Plot Results>Def+undeformed, OK; 
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12. Calculation of the 1st natural frequency of the beam with taking into account the prestressing force 

F (after the static solution with prestress on the stres stiffness matrix is alredy known) 

Solution>Analysis Type>New Analysis..., Modal, OK; 

Solution>Analysis Type>Analysis Options..., No. of modes to extract = 1, 

 No. of modes to expand = 1, OK, OK; 

Solution> Solve> Current LS, OK; 

13. 1st natural frequency 

General Postproc>Results Summary;      

Result: Freq = 13.08 Hz 

14. Calculation of the 1st natural frequency of the beam without prestress 

Solution>Analysis Type>Analysis options, Incl prestress  effects? = No, OK, OK; 

Solution> Solve> Current LS, OK; 

General Postproc>Results Summary,     

Result: Freq = 8.98 Hz 

15. Static calculation of beam with taking into account the prestressing force F (nonlinear problem)  

Solution>Analysis Type>New Analysis>Static, OK; 

Solution>Sol'Controls>Analysis Option, Large Displacement Static, Time at end of load step = 1, 

Number of substeps = 5, Max. no. of substeps = 10, Min. no of substeps = 1, OK; 

Solve, Current LS, OK; 

General Postproc> Plot Results, Def +undeformed, OK; 

   

 
 

16. End of job 

Ansys Toolbar>Quit>Save Geom+Loads, OK; 

 

     The calculation showed the importance of taking into account the prestressing effects for problems 

of this type: The maximum deflection without the prestressing effect (linear calculation) is 44.52 mm, 

the prestressing force F reduced it to 21.18 mm. The prestressing also increased the transverse 

(bending) stiffness of the beam and increased the first natural frequency of the beam from 8.98 to 

13.08 Hz. 

 

     Returning now to the beam element in Fig. 10.1. The element is fixed on the one side and loaded 

with the compressive force F on the other. Its stiffness matrix is expressed in (10.1) as the sum of the 
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material and geometric stiffness matrix. It can be seen that as the absolute magnitude of force F 

increases a diagonal term of the matrix K may be zero and the matrix will be singular. We have 

already mentioned such a situation in the previous sections and we called such a state of the body as 

the bifurcation point, equilibrium split point or stability loss point. The load that this condition causes 

is called a critical load. 

      A matrix is singular when its determinant equals zero, so the critical value of force F in (10.1) is 

calculated from the condition det K = 0. For simplicity of calculation we use unit values of the 

problem parameters and the condition is 
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For the calculation we use a simple program 

m={{1,0,0}, 

{0,12-6x/5,-6+x/10}, 

{0,-6+x/10,4-2x/15}}; 

Det[m] 

Solve[3x^2/20-26x/5+12==0,x]//N 
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-

26x
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{{xØ2.48596},{xØ32.1807}} 

 

We got = 2.486 N. The critical (buckling, Euler) force for such a case of the beam is  

2 2

2
2 47

44
krit

EI
F ,

l

π π
= = = N  

which is a good approximation for one element. In practice, we would get an identity when 

dividing the beam into several elements. 

     The above procedure for calculating the critical load value for a structure with a tendency 

to loss of stability can be generalized and is called linearized buckling. At this problem the 

FEM program solves the generalized problem of eigenvalues 

 ( )lin crit G critK K 0φ =φ =φ =φ =λ+  (10.3) 

where critλ  is the critical load factor of the structure and the vector critφφφφ  contains the 

normalized displacement amplitudes of the structure model nodes after the loss of stability. 

This is analogous to the calculation of the body's natural frequencies and eigenmodes but now 

only the first eigenvalue and the first eigenmode have physical meaning. The calculation is 

simple but has its limitations: 
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1. Stiffness matrices determined for the undeformed body position are used in the calculation 

and therefore the results are reliable only for situations where the assumptions of the linear 

problem are not violated before the critical state (there are no significant displacements, 

rotations and deformations). 

2. Under loading, the assumption of a linear increase of all loads and stresses proportional to 

the multiplier λ  holds. 

3. There are no significant geometrical, load and material imperfections on the body 

4. It is not necessary to determine what happens to the body after loss of stability 

 

If these conditions are not met, the stability problem has to be solved as geometrically, resp. 

as a physically non-linear problem. However, in their validity, the linearized buckling 

provides usable results, practically identical to the iterative nonlinear calculation. If we can 

neglect the effect of self-weight, so the buckling of straight rods, beams and loss of stability 

of rotationally symmetrical shells and bodies are typical cases where linearized buckling can 

be used. 

 

     In the case of real structures, the conditions for linearized buckling are usually not fulfilled 

and therefore it is recommended to calculate the so-called loss of stability limit load by 

nonlinear strength calculation. It is actually a static non-linear FEM calculation with a 

gradually increasing load up to a state where the body collapses or a sharp transition to 

another (equilibrium) state, manifested either by divergence or a strong instability of the 

iterative procedure. The result is then judged by suitable means of a graphic or numerical 

postprocessor. The great advantage of such a procedure is the possibility of incorporating and 

taking into account the effect (assumed, estimated) imperfections, which on the real structures 

always exist (pressure forces outside the neutral cross-sectional axis, failure to make the ideal 

shape, material inhomogeneities and cracks, the possibility of weakening the strength by local 

exceedance of the yield limit, significant changes in geometry during loading, etc.). The 

mechanism of structural stability loss with imperfections can differ significantly from the 

idealized linearized calculation mechanism. 

Consider the steel beam in Fig. 10.1 with values L  = 2000 mm, E = 200000 MPa and a 

circular cross section with I = 1000 mm
4
. In an ideal state, under the load of compressive 

force F and neglecting its own weight, the critical buckling force is      

2 2

2 2

200000 1000
123 37

4 4 2000
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EI
F ,

L

π π ⋅
= = =

⋅
N  

     If the force F acts outside the center of gravity of the cross-section with eccentricity e, the 

relationship between the force and the maximum deflection (at the free end of the beam) can 

be determined according to the relations for the bending-buckling combination [19] 

( )
1

1 1
cos kL

v e cos kL
cos kL

− 
= + − 

 
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Fig. 10.4 

where k F EI= . The dependence is shown in Fig. 10.4 We can see the difference from the 

ideal state (e = 0), which is result at the linearized calculation. The bifurcation point 

disappears, the beam can acquire unacceptably large deflections even before reaching the 

critical force value. It is a simple illustration that, with the exceptions mentioned above, real 

structures need to be checked by non-linear analysis. 

     In the following two examples, we will show the computational procedure for solving the 

loss of stability in ANSYS. Both bodies are without imperfections and for comparison we will 

solve them by both mentioned procedures. In the first example, the body fulfills the 

conditions for linearized calculation, the second violates them by precluding the actual 

collapse of the body by significant movements and rotations of the body. 

 
Example 10.2 

     For a planar ring with a square cross-section and a a×  in the figure 10.5, determine the critical 

value of the continuous load q first by using a linearized buckling and then by a non-linear calculation. 

The ring can only deform in its plane and we assume the linear elastic properties of the material under 

load. It is given: R = 0.5 m, a = 1 cm, E = 2 E11 Pa. 

Theoretical solution gives [20]  

                                                     

11 41
12

3 3

3 2 10 0 013
4000 N / m

0 5
crit

,EI
q

R ,

⋅ ⋅
= = =  

 

 

 
 

 

 

 

 

 

1. Job name 

Utility Menu>File>Change Jobname... /FILNAM = RING; 

2. Element type 

Preprocessor>Element Type>Add/Edit/Delete, Add... Beam 3node 189, OK, Close; 

3. Cross-sectional data 

Preprocessor>Sections>Beam>Common Sections... Sub-Type:     , B = 0.01, H = 0.01, OK; 

Fcrit 

e=0 e=
0.
00
1L

e=0
.0
00
5L

e=0.000
1L

Ra

q



8 

 

4. Material properties 

Preprocessor>Material Props>Material Models... Favorites, Linear Static, Linear Isotropic, EX = 

2e11,  PRXY = 0.3, OK, Material, Exit; 

5. Center circle of the ring 

Preprocessor>Modeling>Create>Lines>Arcs>Full Circle, Global Cartesian: 0, 0, 0, OK, 0.5, OK; 

6. Help point for the mass creation of the third node of elements (the simplest is at the beginning of the 

coordinate system) 

Preprocessor>Modeling>Create>Keypoints>In Active CS, OK; 

7. Specify the orientation of the lines for mass creation of the third node 

Preprocessor>Meshing>Mesh Attributes>All Lines... Pick Orientation Keypoint = Yes, OK, Click: 

KP5 (the center of the circle), OK; 

8. Meshing of elements 

Preprocessor>Meshing>Mesh Tool, Lines, Set, Pick All, NDIV = 8, OK, Mesh, Pick All; 

9. Fixing the ring (removing rigid movement) 

Solution>Define Loads>Apply>Structural>Displacement>On Keypoints, Click: Top and bottom 

point , OK, Mark UX, Apply, Click: Left and right point, OK, Mark (only) UY, 

Apply, Click all 4 points of the circle, OK, Mark UZ, ROTX, ROTY, KEXPAND = 

Yes, OK; 

Save_DB; 

10. Enter the unit continuous load 

Solution>Define Loads>Apply>Structural>Pressure>On Beams, Pick All, VALI = -1, OK;  

11. Stress stiffnes matrix calculation 

Solution>Analysis Type>Sol’Controls... Calculate prestress effects = ON, OK; 

Solution> Solve> Current LS, OK, Finish; 

12. Calculation of critical multiplier of input load and shape of loss of stability (linearized buckling) 

Solution>Analysis Type>New Analysis... Eigen Buckling = ON, OK; 

Solution>Analysis Type>Analysis Options... NMODE = 1, OK; 

Solution> Solve> Current LS, OK; 

13. Listing of critical load multiplier 

General Postproc>Results Summary...:    kritλ  = 3998.4 

14. Drawing the shape of the center line of the ring when losing stability 

ANSYS Main Menu> General Postproc> Read Results... Last Set; 

ANSYS Main Menu> General Postproc> Plot Results>Deformed Shape... Def +undeformed, ON, OK; 
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15. Changing the problem and entering parameters for the non-linear calculation  

Solution>Analysis Type>New Analysis... STATIC, OK; 

Solution>Analysis Type>Sol’n Controls... Large Displacement Static, Time at end of substep = 1.0, 

Number of substeps = 150, Automatic time stepping = OFF, Frequency: Write every 

substep, OK; 

16. Entering the load at the end of the first step 

Solution>Define>Loads>Apply>Structural>Pressure>On Beams, Pick All, VALI = -5000, OK; 

17. Violation of rotational symmetry by a low force load 

Solution>Define>Loads>Apply>Structural>Force/Moment>On Keypoints ↑ Click the left point of 

the circlee, OK, Lab = Fx, VALUE = 10, OK; 

18. Nonlinear calculation 

Solution> Solve>Current LS, OK; 

19. Draw of ring shape under 5000q = N/m load (it's a new equilibrium shape at this load) 

General Postproc>Read Results>Last Set; 

General Postproc>Plot Results>Deformed Shape... Def + undeformed, ON, OK; 

 

20. Draw of the displacement of the left point of the central circle of the ring  

TimeHist Postpro>Variable Viewer... Click the first icon from left, Nodal Solution, DOF Solution, X-

Component of displacement, OK, Click the Circle left point, OK, Click the third icon from left; 

 

21. End of job 

Ansys Toolbar>Quit>Save Geom+Loads, OK; 
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     The linearized calculation gave a critical pressure value 
crit

q = 3998.4 N/m, which is practically 

identical to the theoretical solution. The value of the critical pressure in a non-linear solution can be 

obtained from the above graph of dependence of increasing load and vertical displacement of the 

upper point of the central circle of the ring: The sharp displacement increase occurred at the value of   

0,8 5000 4000critq ≈ ⋅ = Pa. A more accurate view of the critical point can be obtained by displaying a 

graph in iterval of 0.75 to 0.85 times the load time. The use of linear buckling is, as can be seen, 

justified in this case. 

     In a non-linear calculation, the ideal rotationally symmetrical problem must be disrupted by a small 

force or deformation imperfection in order to get a smal bend. 

Example 10.3 
 

 

For a curved planar beam (arc) in the figure with square cross section 

a a× , determine the critical value of force F by first calculating the 

linearized buckling and then by a non-linear calculation. The beam can 

deform only in its plane and we assume linear elastic properties of the 

material under load. It is given: R = 1 m, a = 4 mm, E = 2 E11 Pa, 

20α= �

. 

Perform the non-linear calculation by the arc-length method [5], [14]. 

 

 

 

 

1. Job name 

Utility Menu>File>Change Jobname, /FILNAM = ARC; 

2. Element type, material properties and cross-sectional data 

Preprocessor>Element Type>Add/Edit/Delete, Add, Beam 3node 189, OK, Close; 

Preprocessor>Material Props>Material Models, Favorites, Linear Static, Linear Isotropic, EX = 

2e11,  PRXY = 0.3, OK, Material, Exit; 

Preprocessor>Sections>Beam>Common Sections... Sub-Type:     , B = 0.004, H = 0.004, OK; 

3. The center line of the arc 

Utility Menu>WorkPlane>Change Active CS to>Global Cylindrical; 

Preprocessor>Modeling>Create>Keypoints>In Active CS, X = 0, Y = 0, Apply, X = 1, Y = 70, 

Apply, X = 1, Y = 90, Apply, X = 1, Y = 110, OK; 

Preprocessor>Modeling>Create>Lines>Lines> In Active CS, Click KP2, KP3, KP3, KP4, OK; 

4. Orientation of lines for mass creation of the third node 

Preprocessor>Meshing>Mesh Attributes>All Lines, Pick Orientation Keypoint = Yes, OK, Click KP1 

(The center point of the arc line), OK; 

5. Elements 

Preprocessor>Meshing>Mesh Tool... Lines, Set, Pick All, NDIV = 8, OK, Mesh, Pick All, Close; 

6. Fixating 

Solution>Define Loads>Apply>Structural>Displacement>On Nodes, Click the left and right point of 

the arc, OK, Select All DOF;  

Solution>Define Loads>Apply>Structural>Displacement>On Keypoints, Click all three keypoints of 

the line, OK, Select UZ, ROTX, ROTY, KEXPAND = Yes, OK; 

Tool bar: SAVE_DB;  

 

F

R
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7. Enter the unit force 

Solution>Define>Loads>Apply>Structural>Force/Moment>On Keypoints, Click the line center, FY 

= -1, OK; 

8. Stress stiffnes matrix calculation 

Solution>Analysis Type>Sol’Controls, Calculate prestress effects = ON, OK; 

Solution> Solve> Current LS, OK;  

Finish 

9. Calculation of critical multiplier of input load and shape of loss of stability (linearized buckling) 

Solution>Analysis Type>New Analysis, Eigen Buckling = ON, OK; 

Solution>Analysis Type>Analysis Options, NMODE = 1, OK, OK; 

Solution> Solve> Current LS, OK; 

10. Listing of critical load multiplier 

General Postproc>Results Summary:    kritλ  = 266.63 

11. Drawing the shape of the center line of the arc when losing stability 

ANSYS Main Menu> General Postproc> Read Results, Last Set; 

ANSYS Main Menu> General Postproc> Plot Results>Deformed Shape, Def +undef edge, ON, OK; 

DISPLACEMENT

STEP= 1
SUB = 1
FREQ= 266.625
DMX = .113918

 

12. Parameters for nonlinear calculation 

Solution>Analysis Type>New Analysis... STATIC, ON, OK; 

Solution>Analysis Type>Sol’n Controls...Advanced NL: Activate arc-length method: ON, Arc-length 

termination: Terminate at first limit, Basic: Time = 0, Large Displacement Static, 

Number of substeps = 500, Write every substep,OK; 

13. Force 

Solution>Define>Loads>Apply>Structural>Force/Moment>On Keypoints, Click the center of the 

arc, OK, FY = -300, OK; 

14. Nonlinear calculation 

Solution> Solve> Current LS, OK, Yes; 

15. Plot of arc shape under critical load 

General Postproc>Read Results>Last Set; 

General Postproc>Plot Results>Deformed Shape... KUND : Def + undeformed 

 
DISPLACEMENT

STEP= 1
SUB = 41
TIME= .601876
DMX = .020562

 
 

16. Plot the displacement of the upper point of the center line of the arc 

TimeHist Postpro>Variable Viewer (reject the proposal to delete the database!) ... 

Click the first icon from left (Add Data), Nodal Solution, DOF Solution, Y-Component of 

displacement, OK, Click the arc high point, OK, Click the third icon from left (Graph Data); 
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17. End of job 

Ansys Toolbar>Quit>Save Geom+Loads, OK; 

      

     The linearized calculation (linearized buckling) determined the magnitude of the critical force 

critF = 266.6 N. The critical force value of the non-linear solution can be obtained from the graph of 

increasing force versus vertical displacement of the upper center line of the arc: The program 

determined the critical situation at 
krit 0 6 300 180 NF ,= ⋅ = . Difference in critical force values is not 

negligible and it should be noted that the linearized calculation gives the result on the "dangerous 

side". 

     In these stability examples we assumed a linear elastic material. For real problems with real 

material it would be a very dangerous mistake to forget the possibility that the equivalent tensile stress 

at the most stressed points of the body can exceed the yield limit of the material before reaching the 

critical load in a purely geometrically nonlinear solution. Even with the least doubt about this, such a 

stability problem must be solved also as the materially nonlinear. 

 

 


